通达信精准启动主图指标公式 更多金钻指标免费QQ群:210919616

精准启动:=1;
精准启动1:=2;
日:=150;
昨前:=3;
高1:=REF(HHV(H,日),昨前);
顶:REFDATE(高1,DATE),COLORBLACK;
绝顶:=REFDATE(顶,DATE),NODRAW;
跑:=绝顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),NODRAW;
STICKLINE(跑,C,O,3,0),COLOR777777;
STICKLINE(跑,C,O,2,0),COLORAAAAAA;
STICKLINE(跑,C,O,1,0),COLORCCCCCC;
STICKLINE(跑,C,O,0.1,0),COLORFFFFFF;
STICKLINE(跑,L,H,0,0),COLORFFFFFF;
DRAWTEXT(跑,C*1.06,'绝顶')COLORFFFFFF;
{反线}
长周期:EMA(CLOSE,250),NODRAW,COLOR8000FF;
NOTEXTA:IF(长周期>=REF(长周期,1),长周期,DRAWNULL),COLORRED,LINETHICK4,POINTDOT;
NOTEXTB:IF(长周期<REF(长周期,1),长周期,DRAWNULL),COLOR006A6A,LINETHICK4,POINTDOT;
T:=FINDHIGHBARS(H,60,30,1);
A:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,H,ISLASTBAR,REF(H,T),0),COLORYELLOW;
TT:=BARSLAST(C>A*1.014 AND L<A);
TA:=BARSLAST(CROSS(A!=DRAWNULL,0.5));
TJ:=VOL=HHV(VOL,T+1) AND TA>28;
TJ1:=COUNT(EXPMA(C,2)>=A,TA+1)=1 AND EXPMA(C,2)>=A*1.01;
E13:=EXPMA(C,TA+1);
CJ:=(A/E13-1) *100 ;
HH:=HHV(CJ,10);
XG:=COUNT(TT=0,T+1)=1 AND TT=0 AND TJ AND TJ1 AND HH<20;
STICKLINE(XG,H,L,0,0),COLORFF00FF;
STICKLINE(XG,C,O,3,0),COLOR990099;
STICKLINE(XG,C,O,2,0),COLORBB00BB;
STICKLINE(XG,C,O,1,0),COLORDD00DD;
STICKLINE(XG,C,O,0.3,0),COLORFF00FF;
DRAWICON(XG,L*0.93,25);
DRAWTEXT(TA=0,A*1.05,STRCAT(STRCAT('最高价:',VAR2STR(REF(A,TA),2)),'元'))COLORYELLOW;
上升线:EMA(C,3),COLORRED,LINETHICK2;
下降线:EMA(C,5),COLOR00FF00,LINETHICK2;
中间线:EMA(下降线,5),COLORWHITE,LINETHICK2;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA((CLOSE-VAR2),6,1)/SMA(ABS(CLOSE-VAR2),6,1)*100;
VAR4:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VAR5:=EMA(0.667*REF(VAR4,1)+0.333*VAR4,5);
VAR6:=IF(VOL>=1.3*MA(VOL,5) AND COUNT(VAR4>=VAR5 AND VAR4<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0);
VAR7:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
VAR8:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
VAR9:=IF(COUNT(VAR8<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWICON(FILTER(REF(VAR3,1)>81 AND VAR3<80 OR CROSS(82,VAR7),5),HIGH,2);
DRAWTEXT(FILTER(REF(VAR3,1)>81 AND VAR3<80 OR CROSS(82,VAR7),5),HIGH,'快卖'),COLORYELLOW;
DRAWTEXT(FILTER(VAR9 OR VAR6,5),LOW,'注意买入'),COLORRED;
DRAWICON(FILTER(CROSS(上升线,下降线)AND 中间线>=REF(中间线,1)AND VAR3<50,5),上升线,1);
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
STICKLINE( ZT,C,O,2,0),COLORYELLOW;
巨量平台:REF(H,BARSLAST(V=HHV(VOL,120)))DOTLINE,COLORWHITE,LINETHICK1;
XG1:= NOT(REF(巨量平台,1)=巨量平台) AND ZT;
DRAWTEXT(XG1,L,'量爆'),COLORCYAN;
操:=MA(C,5);
分界:HHV(操,13)DOTLINE,COLORFFB9CC;
精准扫描:BACKSET(CURRBARSCOUNT=13,42),NODRAW;
划线范围:BACKSET(CURRBARSCOUNT=0,55),NODRAW;
X_3:=IF(CURRBARSCOUNT<=55 AND CURRBARSCOUNT>=13 AND 精准扫描,CONST(REF(LOW,精准启动)),DRAWNULL);
辅助线1:IF(CURRBARSCOUNT<=55 AND 精准扫描=0,CONST(REF(LOW,精准启动)),DRAWNULL),DOTLINE,COLORRED;
有效K线1:精准扫描 AND ABS((MAX(OPEN,CLOSE)-X_3)/X_3*100)<=1.5,NODRAW;
满足1:COUNT(有效K线1,55)>=3,NODRAW;
成立线1:IF(CONST(满足1),X_3,DRAWNULL),COLORGREEN,LINETHICK2;
STICKLINE(有效K线1,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(有效K线1,LOW,HIGH,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=精准启动+1,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=精准启动+1,LOW,HIGH,0,0),COLORMAGENTA;
X_4:=IF(CURRBARSCOUNT<=55 AND CURRBARSCOUNT>=13 AND 精准扫描,CONST(REF(LOW,精准启动1)),DRAWNULL);
辅助线2:IF(CURRBARSCOUNT<=55 AND 精准扫描=0,CONST(REF(LOW,精准启动1)),DRAWNULL),DOTLINE,COLORRED;
有效K线2:精准扫描 AND ABS((MAX(HIGH,CLOSE)-X_4)/X_4*100)<=1.5,NODRAW;
满足2:COUNT(有效K线2,55)>=2,NODRAW;
成立线2:IF(CONST(满足2),X_4,DRAWNULL),COLORGREEN,LINETHICK2;
STICKLINE(有效K线2,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(有效K线2,LOW,HIGH,0,0),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=精准启动1+1,OPEN,CLOSE,2,0),COLORWHITE;
STICKLINE(CURRBARSCOUNT=精准启动1+1,LOW,HIGH,0,0),COLORWHITE;
昨日收盘:IF(CURRBARSCOUNT<=5,CONST(REF(C,1)),DRAWNULL);


选股票看什么指标最好 >股票指标网