通达信全面开花主图指标 更多金钻指标免费QQ群:210919616
N:=5;A1:=REF(H,N)=HHV(H,2*N+1);

B1:=FILTER(A1,N);

C1:=BACKSET(B1,N+1);

D1:=FILTER(C1,N);

R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);

S11:=R11 > REF(R11,1);

A2:=REF(L,N)=LLV(L,2*N+1);

B2:=FILTER(A2,N);

C2:=BACKSET(B2,N+1);

D2:=FILTER(C2,N);

T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);

U11:=T11 > REF(T11,1);

M:=INTPART(3*N/5);

A12:=REF(H,M)=HHV(H,2*M+1);

B12:=FILTER(A12,M);

C12:=BACKSET(B12,M+1);

D12:=FILTER(C12,M);

R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1);

S112:=R112 > REF(R112,1);

A22:=REF(L,M)=LLV(L,2*M+1);

B22:=FILTER(A22,M);

C22:=BACKSET(B22,M+1);

D22:=FILTER(C22,M);

T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1);

U112:=T112 > REF(T112,1);

VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);

VAR2222:=CROSS(VAR1111,0.9);

VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);

VAR4444:=CROSS(VAR3333,0.9);

压力:= REF(HIGH,BARSLAST(VAR2222));

支撑:= REF(LOW,BARSLAST(VAR4444));

下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

RRRSV:=SMA(下档线,3,1);

KKK:=SMA(RRRSV,3,1);

DDD:=((3 * RRRSV) - (2 * KKK));

JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

RSV24:=SMA(JJ12,3,1);

K24:=SMA(RSV24,3,1);

D24:=((3 * RSV24) - (2 * K24));

压力2:=IF(CROSS(D24,DDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD)))),COLORFFFFFF;

压力位:=IF(ISLASTBAR,压力2,DRAWNULL);

底部:=LLV(HIGH,30),COLOR00FF00;

底部位:=IF(ISLASTBAR,底部,DRAWNULL);

AA05:=MA(C,5),COLOR0099CC;

五日乖离率:=(C-AA05)/AA05*100;

BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);

加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;

AA10:=MA(C,10);

AA20:=MA(C,20);

BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;

AA30:=MA(C,30);

三拾日乖离率:=(C-AA30)/AA30*100;

VAR11:=(AA20-AA30) > REF((AA20-AA30),1)AND AA20 > REF(AA20,1) AND AA30 > REF(AA30,1);

VAR22:=(AA30-AA20) < REF((AA30-AA20),1) AND AA20 < REF(AA20,1) AND AA30 < REF(AA30,1);

BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;

强势狙击:=FILTER(BB30 > 30 AND BB10 > 45 AND CROSS(BB05,60),10);

加仓:=FILTER(COUNT(CROSS(BB05,30),5) >=1 AND AA05 > REF(AA05,1) AND 三拾日乖离率 > REF(三拾日乖离率,1) AND AA10 > REF(AA10,1)AND 加速度5 > REF(加速度5,1) AND 速度5 > REF(速度5,1) ,10) ;

清仓:=FILTER(COUNT(CROSS(30,BB05),5) >=1 AND (C > AA30 OR O > AA30) AND AA05 < REF(AA05,1) AND 三拾日乖离率 < REF(三拾日乖离率,1) AND AA10 < REF(AA10,1),10);

TYP := (HIGH + LOW + CLOSE)/3;

CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));

差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;

CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));

差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;

CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));

差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;

CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));

差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;

CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));

差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;

CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;

AAA:=(3*C+H+L+O)/6;

VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;

VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;

VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;

VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;

VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;

VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;

TJ1:= CCI1 > 差值4;

立桩量:=FILTER(TJ1,0);

TJ2:=IF(BARSLAST(立桩量)=1 ,1,IF(BARSLAST(立桩量)=2 ,1,IF(BARSLAST(立桩量)=3 ,1,0)));

成立1:=TJ2;

条件成立1:=FILTER(成立1,5);

TJ11:= CCI1 < -差值4 ;

立桩量2:=FILTER(TJ11,0);

TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSE > REF(HIGH,1),1,IF(BARSLAST(立桩量2)=2 AND CLOSE > REF(HIGH,2),1,IF(BARSLAST(立桩量2)=3 AND CLOSE > REF(HIGH,3),1,0)));

成立2:=TJ22;

条件成立2:=FILTER(成立2,5);

TJ111:=(ABS(CCI1) > CCI AND ABS( 差值1) > ABS(差值5))OR (VOL=HHV(VOL,10) AND VOL > 2*REF(VOL,1) AND CLOSE > VAR1);

立桩量3:=FILTER(TJ111,5);

TJ222:=IF(BARSLAST(立桩量3)=1 AND CLOSE > REF(HIGH,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE > REF(HIGH,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE > REF(HIGH,3),1,0)));

突破3:=TJ222=1;

TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE > REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE > REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE > REF(LOW,3),1,0)));

三天法则:=TJ3=1;

成立:=三天法则 AND 突破3;

条件成立:=FILTER(成立,5);

TJ31:=(VOL=HHV(VOL,10) AND VOL > 2*REF(VOL,1) AND CLOSE > VAR1);

TJ32:=FILTER(TJ31,1);

趋势线:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,LINETHICK4;

DRAWLINE(D1,H,S11,H,1),COLORFF00FF;

DRAWLINE(D2,L,U11,L,1),COLORFF00FF;

DRAWLINE(D12,H,S112,H,1),COLOR0000FF;

DRAWLINE(D22,L,U112,L,1),COLOR0000FF;

STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST(VAR2222)),0.5,1),COLOREA91B5,LINETHICK3;

STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444)),REF(LOW,BARSLAST(VAR4444)),0.5,1),COLOR00B4FF,LINETHICK3;

STICKLINE(ISLASTBAR ,压力位,压力位,120,0),LINETHICK4,COLORFFFFFF;

STICKLINE(ISLASTBAR ,底部位,底部位,100,0),LINETHICK4,COLOR00FF00;

DRAWICON(加仓 ,LOW*0.97,23);

DRAWICON(清仓 ,HIGH*1.01,19);

DRAWICON(强势狙击 ,LOW*0.99,13);

短线:VAR1,COLORWHITE;

中线:VAR6,COLORYELLOW;

DRAWBAND(短线,RGB(255,255,0),中线,RGB(256,200,0));

下跌:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;

STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量3)),REF(HIGH,BARSLAST(立桩量3)),10,1),COLORCYAN;

STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立桩量3)),REF(LOW,BARSLAST(立桩量3)),10,1),COLORYELLOW;

IF(条件成立 AND 下跌!= VAR6 AND AA30 >=REF(AA30,1),H*1.03,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF33FF;

IF(条件成立 AND 下跌!= VAR6 AND AA30 >=REF(AA30,1),H*1.03,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;

STICKLINE(C >=O,L,H,0,0),COLORRED;

STICKLINE(C < O,L,H,0,0),COLORFFFF00;

STICKLINE(C > O,C,O,3.5,0),COLORRED;

STICKLINE(1,C,O,2.8,0),COLOR666600;

STICKLINE(1,C,O,2,0),COLOR999900;

STICKLINE(1,C,O,1.5,0),COLORBBBB00;

STICKLINE(1,C,O,1,0),COLORDDDD00;

STICKLINE(1,C,O,0.5,0),COLORFFFF00;

STICKLINE(立桩量,C,O,2.8,0),COLOR000066;

STICKLINE(立桩量,C,O,2,0),COLOR0000BB;

STICKLINE(立桩量,C,O,1.5,0),COLOR0000CC;

STICKLINE(立桩量,C,O,1,0),COLOR0000DD;

STICKLINE(立桩量,C,O,0.3,0),COLOR0000FF;

DRAWICON(条件成立1,REF(HIGH,BARSLAST(立桩量3)),12);

DRAWICON(条件成立2,REF(LOW,BARSLAST(立桩量3)),11);


选股票看什么指标最好 >股票指标网