同花顺资仓管理指标公式 更多金钻指标免费QQ群:210919616
m5=0;
m10=0;
m20=0;
m30=0;
m60=0;
a2=MA(C,1);
a5=MA(C,5);
a10=MA(C,10);
a20=MA(C,20);
a30=MA(C,30);
a60=MA(C,60);
IF(a5=NULL)m5=100;
IF(a2&-gt;=a5)
{
m5=100;
IF(a2&-gt;=a10)
{
m10=0;
IF(a2&-gt;=a20)
{
m20=0;
IF(a2&-gt;=a30)
{
m30=0;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-100;
}
}
IF(a2&-lt;a30)
{
m30=-70;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-30;
}
}
}
IF(a2&-lt;a20)
{
m20=-50;
IF(a2&-gt;=a30)
{
m30=0;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-50;
}
}
IF(a2&-lt;a30)
{
M30=-20;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-30;
}
}
}
}
IF(a2&-lt;a10)
{
m10=-50;
IF(a2&-gt;=a20)
{
m20=10;
IF(a2&-gt;=a30)
{
m30=0;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-60;
}
}
IF(a2&-lt;a30)
{
m30=-30;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-30;
}
}
}
IF(a2&-lt;a20)
{
m20=-10;
IF(a2&-gt;=a30)
{
m30=0;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-40;
}
}
IF(a2&-lt;a30)
{
m30=-20;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-20;
}
}
}
}
}
IF(a2&-lt;a5)
{
m5=0;
IF(a2&-gt;=a10)
{
m10=50;
IF(a2&-gt;=a20)
{
m20=20;
IF(a2&-gt;=a30)
{
m30=10;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-80;
}
}
IF(a2&-lt;a30)
{
m30=-40;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-30;
}
}
}
IF(a2&-lt;a20)
{
M20=0;
IF(a2&-gt;=a30)
{
m30=0;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-50;
}
}
IF(a2&-lt;a30)
{
m30=-20;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-30;
}
}
}
}
IF(a2&-lt;a10)
{
m10=0;
IF(a2&-gt;=a20)
{
m20=50;
IF(a2&-gt;=a30)
{
m30=0;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-50;
}
}
IF(a2&-lt;a30)
{
m30=-20;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-30;
}
}
}
IF(a2&-lt;a20)
{
M20=0;
IF(a2&-gt;=a30)
{
m30=30;
IF(a2&-gt;=a60)
{
m60=0;
}
IF(a2&-lt;a60)
{
m60=-30;
}
}
IF(a2&-lt;a30)
{
m30=0;
IF(a2&-gt;=a60)
{
m60=10;
}
IF(a2&-lt;a60)
{
m60=0;
}
}
}
}
}
IF(a2&-gt;=a5 AND a2&-gt;=a10 AND a2&-gt;=a20 AND a2&-gt;=a30 AND a2&-lt;a60)m5=150;
IF(a2&-gt;=a5 AND a2&-gt;=a10 AND a2&-lt;a20 AND a2&-gt;=a30 AND a2&-lt;a60)m5=130;
IF(a2&-gt;=a5 AND a2&-gt;=a10 AND a2&-gt;=a20 AND a2&-lt;a30 AND a2&-lt;a60)m5=130;
IF(a2&-gt;=a5 AND a2&-lt;a10 AND a2&-lt;a30 AND a2&-lt;a60)m5=110;
IF(a2&-lt;a5 AND a2&-gt;=a10 AND a2&-gt;=a20 AND a2&-gt;=a30 AND a2&-lt;a60)m5=30;
IF(a2&-gt;=a5 AND a2&-gt;=a10 AND a2&-gt;=a20 AND a5&-gt;=a10 AND a2&-lt;a30 AND a2&-lt;a60)m5=130;
IF(a2&-gt;=a5 AND a2&-gt;=a10 AND a5&-gt;=a10 AND a2&-lt;a20 AND a2&-lt;a30 AND a2&-lt;a60)m5=120;
IF(a2&-gt;=a5 AND a2&-gt;=a10 AND a5&-lt;a10 AND a2&-lt;a20 AND a2&-lt;a30 AND a2&-lt;a60)m5=110;
IF(a2&-gt;=a5 AND a2&-gt;=a10 AND a2&-gt;=a20 AND a2&-gt;=a30 AND a2&-lt;a60 AND a5&-lt;a10 AND a10&-lt;a30)m5=130;
资金仓位:m5+m10+m20+m30+m60;
IF(PERIODNAME&-lt;&-gt;"日线")
{
统计:"该指标只在日线周期下有效。";
RETURN;
}
//大单净量
r:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;
//相对强弱
LC := REF(CLOSE,1);//前一日收盘价;
RSI$1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
RSI$2:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI$3:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
相对强弱:=0.5*RSI$1+0.31*RSI$2+0.19*RSI$3;
wave$1:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),3,1);
wave$2:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),5,1);
wave$3:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),8,1);
短线波段:=0.5*wave$1+0.31*wave$2+0.19*wave$3;
机会区:20,POINTDOT,colorred;
风险区:80,POINTDOT,colorgreen;
风险系数:0.5*相对强弱+0.5*短线波段,coloryellow;
//买入条件;
CD1:=IF(风险系数&-lt;20 AND CLOSE&-gt;OPEN AND r&-gt;0,1,0);//波段小于20,股价翻红;
CD2:=IF(风险系数&-lt;20 AND LOW&-gt;=REF(LOW,1) AND CLOSE&-gt;LOW AND r&-gt;0,1,0);//波段小于20,股价未翻红,但未创新低;
CD3:=IF(REF(风险系数,1)&-lt;20 AND 风险系数&-gt;REF(风险系数,1),1,0);//前一日波段小于20,今日转向;
SIGNALBUY=(CD1=1 OR CD2=1 OR CD3=1);
X=(SIGNALBUY AND COUNT(SIGNALBUY,3)=1);
DRAWICON(X,机会区,"buy");
X_1:=CLOSE-REF(CLOSE,1);
X_2:=100*EMA(EMA(X_1,5),3)/EMA(EMA(ABS(X_1),5),3);
X_3:=100*EMA(EMA(X_1,13),8)/EMA(EMA(ABS(X_1),13),8);
X_4:=X_2&-gt;X_3;
X_5:=IF(X_4,6,0);
X_6:=EMA(CLOSE,8)-EMA(CLOSE,13);
X_7:=EMA(X_6,5);
X_8:=X_6&-gt;X_7;
X_9:=IF(X_8,1,0);
X_10:=(EMA(CLOSE,3)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4;
X_11:=CLOSE&-gt;X_10;
X_12:=IF(X_11,5,0);
X_13:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
X_14:=SMA(X_13,3,1);
X_15:=SMA(X_14,3,1);
X_16:=X_14&-gt;X_15;
X_17:=IF(X_16,2,0);
X_18:=REF(CLOSE,1);
X_19:=SMA(MAX(CLOSE-X_18,0),5,1)/SMA(ABS(CLOSE-X_18),5,1)*100;
X_20:=SMA(MAX(CLOSE-X_18,0),13,1)/SMA(ABS(CLOSE-X_18),13,1)*100;
X_21:=X_19&-gt;X_20;
X_22:=IF(X_21,3,0);
X_23:=(-(HHV(HIGH,13)-CLOSE))/(HHV(HIGH,13)-LLV(LOW,13))*100;
X_24:=SMA(X_23,3,1);
X_25:=SMA(X_24,3,1);
X_26:=X_24&-gt;X_25;
X_27:=IF(X_26,4,0);
X_28:=X_8+X_16+X_21+X_26+X_11+X_4-3;
【持股】:X_28&-gt;0,NODRAW,colormagenta;
【持币】:X_28&-lt;0,NODRAW,colorgreen;
【变盘】:X_28=0,NODRAW,coloryellow;
0,coloryellow;
STICKLINE(【持股】,0,X_28,2,0),colormagenta;
STICKLINE(【持币】,0,ABS(X_28),2,0),colorgreen;
STICKLINE(【变盘】,0,1,2,0),coloryellow;
DRAWICON(【持股】 AND REF(X_28,1)&-lt;=0,-0.8,7);
DRAWICON(【持币】 AND REF(X_28,1)&-gt;=0,-0.8,8);
【必买】:【持股】 AND REF(X_28,1)&-lt;=0 AND CROSS(CLOSE,EMA(CLOSE,5)) AND CROSS(CLOSE,EMA(CLOSE,10)) AND CROSS(CLOSE,EMA(CLOSE,20)) AND LOW&-gt;REF(LOW,1) AND MACD.MACD&-gt;0,NODRAW,colorred;
STICKLINE(【必买】,-0.5,0,3,0),colorred;
STICKLINE(【必买】,-0.5,-1,3,0),coloryellow;
选股票看什么指标最好 >股票指标网